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Overview 
Welcome to the next generation of ExpertCAD & ExpertCAM for Windows.  The applications have 
been transformed into true Windows applications.  As a necessary part of this transformation, the 
user interface has been dramatically changed to adopt Windows-standard features and 
appearance while retaining the unique characteristics such as cursor strokes that makes the 
software so productive. 

 
ExpertCAD 2007 for Windows 

 
This document will serve as your guide to these major changes in the user interface including the 
new features and functions now possible.  Although major changes have been made, you will find 
it very easy to adapt to this new version because wherever possible, Windows standards and 
industry conventions have been followed. 
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Windows User Interface Overview 
This section describes the changes to the user interface.  The examples shown are for 
ExpertCAD.  ExpertCAM has identical or very similar changes to its user interface as well. 
 
General Window Layout 

The same general layout of the window has been retained: 
• Windows menus along the top of the window. 
• Central graphics area for display of the drawing or NC cutter path. 
• Static icons along the right-hand side. 
• Pop-up menus. 
• A message area at the bottom of the screen for prompts and messages. 

 
Status Bar 

A Windows-style status bar has been added to the bottom of the window: 

 
This status bar replaces the old ‘headline’ in previous versions.  Clicking in any of the cells that 
report the current layer, units, etc. will cause a dialog or prompt to allow you to quickly change 
their status just as with the former headline. 
 
In the left-most cell of the status bar, the coordinates of the cursor will be shown & updated as 
you move the cursor around the drawing.  Holding down the ‘Shift’ key while moving the mouse 
will report precise coordinates of geometry nearby: 

 
The left-most cell is also used to show a 1-line help string when tracking icons, menus or pop-up 
menus.  Informational messages are also displayed here such as the coordinates of a point 
dropped or what the last short command just did: 

 
Tracking over any menu item or icon posts a 1-line help message. 

 
A progress meter is shown in the left-most cell for operations that can take more than several 
seconds to complete.  There are 2 styles of progress meters: 

 
The discrete  progress meter is used for operations where actual progress towards completion can be measured. 
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The marquee-style progress meter is shown when a solution is being computed but actual progress towards 
completion can’t be determined. 
   
Keystroke Commands 

Where possible, all the standard factory-settings for keystroke commands have been retained.  
Some important changes to be aware of include: 

• The ‘Esc’ key replaces the Ctrl-C key combination to interrupt an operation.  Whenever you 
wish to interrupt a long-running operation or dismiss a dialog or prompt, hit the ‘Esc’ key.  The 
Ctrl-C combination is the keystroke for Edit/Copy. 

• Because of the change to handling the Esc command, the old key combinations such as Esc-E 
for ‘edit’ are no longer supported. 

• The ‘F1’ key defaults to Help/Contents.  In previous releases, F1 was the keystroke to enter a 
long command from the keyboard.  To enter long commands, use the ‘:’ (colon) key which by 
default performed this function in previous releases. 

 
Throughout the user interface, keystroke commands have been implemented to conform to 
Windows standard.  If there are keystroke commands for a feature/function in a pull-down menu, 
the keystroke is listed in the menu item: 

 

In the File menu, Ctrl+O is the keystroke combination to open 
a file.  Similarly Ctrl-N will start a new drawing.  Both are 
Windows standard keystrokes for these features. 

 

Mouse Button Assignments 

The applications default to the traditional mouse-button assignments although these can be 
changed according to your preferences in the User Preferences tab of the Tools/Options property 
sheet.  By default the button assignments are: 

• Left-mouse button – digitize points & cursor strokes. 

• Middle-mouse button – activate pop-up menus. 

• Right-mouse button – track the static icon area. 

In addition to these 3 standard mouse buttons, support has been added for the ‘Forward’ and 
‘Back’ mouse buttons.  As with previous versions, the scroll wheel can be programmed also.  The 
default settings and other choices are set in the Tools/Options dialog on the User Preferences 
tab: 

 
 
The left-right tilt-wheel, while not programmable, is recognized by the software and by default will 
operate the horizontal scroll bar (scroll-left, scroll-right). 
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In ExpertCAD, default behavior is defined when the Ctrl or Shift key is held down while digitizing 
in the graphics area.  Ctrl will select (or unselect) the entity near the cursor (i.e. toggle the 
selected state).  Shift will select the entity near the cursor adding it to the collections of entities 
currently selected (i.e. add to selection). 
 
Scroll Bars 

Horizontal and vertical scroll bars for scrolling a drawing left/right, up/down are enabled by default 
in ExpertCAD.  The scroll bars function according to Windows standard.  If you wish reclaim 
some graphics area, the scroll bars can be disabled and hidden in the Tools/Options dialog. 
 
Drag & Drop Support 

Windows-standard drag & drop of files into the application window is supported.  In ExpertCAD, if 
a file is currently being edited, the file is inserted into the drawing otherwise the file is opened and 
becomes the current file being edited.  In ExpertCAM, drag & drop functions the same as 
File/Open.  In all cases only 1 file can be specified and it must be of a file format that the 
application can read. 
 
Popup Menus 

Popup menus are Windows-style pull-right menus as opposed to the stacking-style in previous 
releases.  The title of the pull-right appears in the main menu with its contents in the pull-right. 

Pop-up menus are used for those 
features/functions that are dependent on the 
position of the cursor at the time the function is 
used. 
 
If preconditions for using an item in the menu 
are not met, the item is disabled.  In this 
example, there is no current text so the menu 
item Delete Current Text is disabled. 
 
All items in popup menus (graphics and textual 
menus) have 1-line help messages that are 
displayed in the status bar when that item is 
tracked. 

Many of the features implemented in popup menus in previous releases have migrated to the 
pull-down menus.  Operations that require pre-positioning of the cursor are implemented as 
popup menus. 
 
The ‘menustick’ (default menu item) feature is implemented in a Windows standard manner.  The 
default item is in bold text and can be invoked by choosing the text in the main menu. 
 
If you use the library feature, the modules you specify to use will be added to the main popup 
menu: 

 

In this example, the parametrics, mold 
components and user library are requested. 
 
To bring up the user interface for the library, 
choose its icon in the graphics popup menu. 
 
Note that there are 1-line help messages shown in 
the status bar when you track over an icon in any 
graphic popup menu. 
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Here is an overview of the new set of popup menus in ExpertCAD 2007: 

 

The Find Delete menu is a renamed version of 
the former FIN/DEL menu.   
 
The same features and functions are provided 
with menu items that provide for greater clarity. 
 
Notice that menu items are disabled when 
conditions for the proper usage do not exist. 

 

 

 
The Point Edit menu is a renamed version of 
the former PT EDIT menu. 
 
The menu retains the same order and 
functionality as previous releases.  The menu 
items themselves have been modified for 
clarity as to their purpose. 
 
Note the menu item Filter by Class has a 
checkmark next to it.  This indicates that the 
Filter by Class is currently enabled.  Choosing 
this menu item will toggle its state on and off. 
 
Here again, menu items are disabled when 
pre-conditions don’t allow their use.  In the 
example to the left, we don’t have a current line 
enclosing any entities so therefore the Select 
Enclosed functions for point selection are 
disabled.  

 

 
The Measure popup menu is functionally the 
same as in previous releases.  For clarity the 
icons have been revised in appearance and 1-
line help is provided in the status bar when an 
icon is highlighted. 
 

 

Drawing Xtras is a replacement for the former 
DRAW popup menu.  Included in this menu are 
the features that modify the current line most of 
which are dependent on the cursor position. 
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Dialogs 

Windows-style dialogs are used throughout the applications.  The former proprietary dialog look 
and feel has been discarded.  In addition to Windows-standard dialogs, specialized dialogs have 
been added for consistency where required: 

 

The Layer Manager dialog has been converted to a Windows dialog and reworked 
to make it easy to delete, rename or create new named layers because they work 
per Windows standard.   

The Line Style dialog shows 
the true dash pattern and 
width of each line style 
available 

 
 

The Font dialog lists all fonts currently available and provides a preview of your 
selection. 

The color dialog shows all 
available color choices with 
one-click selection. 

 
ExpertCAD Menus 

The menu set has been modified to conform closely to Windows standards and common practice 
for organization and function.  The menus themselves follow Windows standards for usage: 
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The menus can be navigated using your mouse or the keyboard by 
using the Alt keystroke in combination with other keystrokes.  
Underlined characters indicate the key to use to navigate to that item. 
 
If there is a keystroke (short command) associated with a menu item, 
it will be listed on the menu to right of the text for that item (e.g. the 
Del key will perform the same function as Edit/Delete). 
 
In all cases, menu items are disabled if the proper conditions do not 
exist to use that item.  In this example, Redo is disabled because we 
have not done an Undo yet.  Similarly Paste is disabled because 
there is nothing suitable on the clipboard to paste into ExpertCAD. 
 
When you track over a menu item, a 1-line help message will be 
shown in the status bar to describe its function. 

 
The new menu set for ExpertCAD is shown below: 
 

 
 
The following is an overview of the menus that have changed or have been added for ExpertCAD 
2007: 

New – start a new drawing.  This is the same function as the 
former File/Clear menu item. 
Open – edit a drawing.  This is the same function as the former 
File/Edit menu item. 
Save – save the current drawing. 
Save As - save the current drawing to a different file name.  
Note that the file specified becomes the current edit file. 
Save Current Class – save only those drawing items in the 
current class to a file.  Same function as the former Save Class 
menu item. 
Export – write the drawing to a file in your choice of formats: 

 

Options for exporting files can be set on 
the Import/Export tab of the 
Tools/Options property sheet.  
HSF is a new option to output the 
drawing in Hoops Streaming Format.  
This format can be read by popular 
viewing programs such as SolidWorks 
eDrawings. 
Windows Bitmap writes the drawing as 
a .bmp file full size according to the 
current screen resolution and at the 
color depth (32, 24, … bits per pixel). 

  

 
Send To – forward the drawing data as e-mail or to SofTech’s 
Prospector application for NC machining: 
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Note that the Mail option 
may not be compatible 
with e-mail programs other 
than Microsoft Outlook. 

Page Setup – establishes the printer, paper size, orientation and 
margins you wish to use as a default for printing. 
Print – print all or part of the drawing.  Printing options including 
precise scaling can be specified on the Print/Plot tab in the 
Tools/Options property sheet. 
Plot – plot all or part of the drawing using the WinPlot HPGL/2 
plotting application. 
Properties – displays the drawing properties dialog.  This 
replaces the Drawing Mgmt dialog in previous versions. 
Recent Files – lists the last 8 most recent files that were opened 
so you can quickly edit one of them by choosing it from this 
menu. 
 

 

Undo – reverses the effect of the last change to the drawing.  Up to 
10 levels of undo/redo are supported. 
Redo – roll-forward the last operation that was undone. 
Cut – puts only the selected drawing entities on the system 
clipboard and removes them from the drawing. 
Copy – puts only the selected drawing entities on the system 
clipboard. 
Paste – inserts the contents of the clipboard at the current point 
and makes those entities selected. 
Select All – selects all drawing entities. 
Delete – deletes all selected drawing entities. 
 

 
Notes on Cut/Copy/Paste…. 
 
When you use Cut or Copy, the selected entities are written to the system clipboard in 
ExpertCAD format and as a Windows bitmap.  This allows you to paste the items you selected 
into another session of ExpertCAD as drawing entities or into another application that supports 
bitmaps.  For example, you can use Edit/Paste in Microsoft Word to insert an image of what you 
copied in ExpertCAD into a document.  The bitmap picture created by Cut/Copy is dependent on 
the zoom scale at the time you cut or copy the image.  If you need a smaller bitmap image, zoom 
out where zooming in will create a larger image.  It is not necessary for the selected entities to be 
visible in the graphics area for a complete image to be created. 
 
When you use Edit/Paste in ExpertCAD, it will choose to use native ExpertCAD data if it is 
available on the system clipboard.  If that format does not exist, it will choose to use a text format 
if that is available and insert the data as a text note.  This allows you to copy textual data from 
Microsoft Word or Excel into ExpertCAD. 
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The View pull-down menu replaces the former popup View menu in 
previous releases. 
 
Redraw – clears the graphics area and redraws. 
Zoom to Fit – fits the drawing to the graphics area. 
Zoom to Area – zooms into an area you indicate using the mouse.   
Zoom In/Out – dynamic zoom in/out using the mouse. 
Zoom to Scale – set the view scale to a value you specify. 
Zoom by Factor – scale the view scale by a factor you specify. 
Pan – dynamically pan using the mouse. 
Previous View – return the previous view orientation. 
Display Grid – show or disable a visible grid. 

 
 

 

Insert is a new menu that implements certain functions 
formerly found on the File menu. 
 
Drawing – inserts (merges) a drawing into the current 
drawing you are working on.  This is the same function as the 
former File/Merge… menu item. 
New Symbol – creates a symbol from an ExpertCAD file. 
Call to a Symbol – places a call to a symbol at the current 
point.  This is the same function as the former File/Call… 
menu item. 
Update Symbol Definition – updates the definition of a 
symbol from the contents of its original disk file.  This is the 
same function as the former File/Recall… menu item. 

 

 

Tools is a new menu that consolidates various features that 
were formerly scattered throughout other menus in previous 
versions.  
 
Screen Capture – using the mouse, indicate an area of the 
screen to capture as a bitmap and place on the system 
clipboard. 
Engineering Change - posts the engineering change dialog to 
perform a difference between 2 drawings. 
Purge – rids the drawing data of unused and/or unwanted text 
buffers or dimension character definitions. 
Layer Manager – posts the layer manager dialog to delete 
layer names, create new layer names or change layer names. 
Color Editor – posts the color editing dialog to change line 
colors and/or icon colors. 
Options – posts the Options property sheet to set 
preferences. 
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The Draw menu replaces the former POINT and BUILD popup menu.  The same features and 
functions have been consolidated into this single menu: 
 

 

 

 
 
 
 

 

The Draw Menu The Points Submenu The Splines Submenu 
Tools/Options Property Sheet 

The Options property sheet replaces the functions formerly found in dialogs posted from the SET-
UP popup menu.   
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Clicking on a tab on the property sheet brings that dialog to the forefront for entering your 
preferences. 
 
Click OK to accept changes to all the dialogs.  Click Apply to accept changes to the current 
dialog.  The settings will be saved to your personal configuration file: 

C:\<Personal application data>\ SofTech\ExpertCAD\ExpertCAD-Setup.cfg 
Where <Personal application data> is typically: 

Windows 2000/XP - C:\Documents and Settings\<user>\Application Data 
Windows Vista - C:\Users\<user>\AppData\Roaming 

 
Never edit the file ExpertCAD-Setup.cfg.  This file is created and re-written by the Options dialog.  
Any changes or edits you might make will be lost the next time you use the Options dialog to 
change a setting. 
 
Printing from Windows in ExpertCAD and ExpertView 
The print feature has been completely redone to allow more flexibility and choices for output.   
 
Page Setup has been added to the File menu to allow you to choose a default printer and set the 
characteristics for that printer.  The choices you make in the Page Setup dialog will be used as 
the default when you print although you will have the option to choose a different printer and 
settings when the print dialog is posted.  These settings are persistent and will be restored when 
you start future sessions of ExpertCAD.  If you don’t use the Page Setup feature, the default 
settings will be those of the default printer set for your computer. 
 
In the Print/Plot dialog in the Tools/Options property sheet, you can choose to set the scale at 
which you want the drawing to be printed: 
 

 

The Fit drawing to paper switch is enabled by default.  
This means that ExpertCAD will scale the output to fit 
the drawing to the paper size you have chosen taking 
into account the current margins. 

 

 

If you want to print at a specific scale, un-check the 
switch Fit drawing to paper then enter the scale at which 
to print the drawing.  In this example, we’re using 1.0 
which means a full scale drawing. 

 
Regardless of whether you choose the Fit option or a specific scale, the scaling method aligns the 
center of your drawing with the center of the printable area of the page as specified by the paper 
size and margins.  The scale is applied relative to this center point. 
 
Line width replaces the function of the former “Line Width Factor” in previous releases.  Line 
width specifies how wide a 1 pixel wide (e.g. style 0) line on the screen should be drawn when 
printed.  The value specified is always in inch regardless of the system of units. 
 
The ability to print multiple copies is supported provided your printer supports this feature. 
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AutoCAD 2007/2008 Support 
The AutoCAD translators have been updated to allow for read and write of AutoCAD 2007 and 
2008 files.  If you wish to output this version of the AutoCAD format, choose 2007/2008 from the 
Output version menu on the Import/Export tab on the Options dialog: 

 

Platform Support 
Supported platforms for ExpertCAD & ExpertCAM 2007 are: 

 
Computer Operating System Revision Level 
Sun SPARC Solaris 2.5 through Solaris 10 
Hewlett Packard PA-RISC HP-UX 11 
Intel & AMD 32-bit Computers Windows 2000 Service Pack 3 or higher 
Intel & AMD 32-bit Computers Windows XP All 
Intel & AMD 64-bit Computers Windows XP x64 Edition All 
Intel & AMD 32-bit Computers Windows Vista 32-bit Edition All 
Intel & AMD 64-bit Computers Windows Vista 64-bit Edition All 
  
Important Notes about Platform Support 

1.   Windows XP x64, Windows Vista 32-bit & 64-bit require the use of the USB style 
security key.  Parallel port security keys are not supported on these operating systems. 

 2.  If you are installing on Windows 2000, you must make sure you have Windows 2000 
Service Pack 3 or later installed before you attempt to install ExpertCAD.  The software 
will not install correctly nor will it run if you are not at this level of the operating system. 

Installation 
ExpertCAD 2007 is intended to be installed in a different path than previous versions of the 
software. 
 

Do not install the software in the same path as previous releases! 
 
ExpertCAD 2007 is intended to run side-by-side with previous releases.  You do not need to 
remove a previous release from your system prior to or after installing ExpertCAD 2007.  Treat 
this release as if you were installing an entirely new product.  Both ExpertCAD 2007 and 
previous releases are treated as completely separate applications as far as Windows is 
concerned.  They don’t have anything in common in terms of using system resources. 
 
For these reasons, we strongly recommend you accept the default installation path: 
 

C:\Program Files\ExpertCAD 2007 
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After installation, a new program group – ExpertCAD 2007 – is created and added to the start 
menu: 

 
Both ExpertCAD 7.7 and ExpertCAD 2007 are installed on this computer. 

 
One of the final steps during installation is the installation of the driver for Aladdin USB dongles.  
If the driver has not been previously installed or a newer version needs to be installed, this will be 
done by the installation program.  In previous versions the driver installation was performed 
without user interaction however with this release, the dialog shown below will be presented: 

 
Click OK when this dialog is presented and the installation process will proceed. 
 
New Paths for Configuration Files 

Previous versions of ExpertCAD installed all software components underneath the root 
installation directory (e.g. c:\Program Files\ExpertCAD).   This scheme was problematic because 
users without administrative rights could not create or modify certain files as needed to configure 
the software.  This is especially true with the Windows Vista operating system.  With this release 
and future releases, all files and directories that a user may need to modify or manage are 
installed in these directories: 
Common application data – this directory contains files and folders that are used or referenced by 
the software for all users of the computer.  The defaults are: 

O/S Path 
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Windows Vista C:\Program Data\SofTech\ExpertCAD 
Windows XP/2000 C:\Documents and Settings\All Users\Application Data\SofTech\ExpertCAD 
 
Personal application data – this directory contains files and folders that are used by the software 
for a particular user of the computer.  Therefore this directory will be different for each user.  The 
defaults are: 

O/S Path 
Windows Vista C:\Users\<user>\AppData\Roaming 
Windows XP/2000 C:\Documents and Settings\<user>\Application Data 
Where <user> is the user login.  Underneath these folders, the folder SofTech and subfolder 
ExpertCAD is created.  For example, on Windows Vista: 

C:\Users\<user>\AppData\Roaming\SofTech\ExpertCAD 
 
If you are unsure about the location of these folders, choose the File Locations tab on the Options 
property sheet in ExpertCAD: 

 
 
 
 
Data files and directories affected by this change include: 
 
ExpertCAD Stroked Font Files (cadFont1, cadFont2, …) 
 Old Path:  C:\Program Files\ExpertCAD\fonts 
 New Path:  C:\ProgramData\SofTech\ExpertCAD\Fonts 
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ExpertCAD Macro Libraries (Init_us, Icons_us, Init_pm, Icons_pm) 
 Old Path:  C:\Program Files\ExpertCAD\expcad\libs 
 New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAD Libraries 
 
ExpertCAM Macro Libraries (Init_us, Icons_us) 
 Old Path:  C:\Program Files\ExpertCAD\expcam\libs 
 New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAM Libraries 
 
AutoCAD Translator Configuration Files 
 Old Path:  C:\Program Files\ExpertCAD\AutoCAD 
 New Path:  C:\Progra Data\SofTech\ExpertCAD\AutoCAD 
 
WinPlot Plotcap.txt File 

Old Path:  C:\Program Files\ExpertCAD\winplot\plotcap.txt 
New Path:  C:\ProgramData\SofTech\ExpertCAD\WinPlot\plotcap.txt 

 
Custom Mold Components 

Old Path:  C:\Program Files\ExpertCAD\expcad\data\mold 
New Path:  C:\ProgramData\SofTech\ExpertCAD\Mold Components 

 
ExpertCAD User Interface Macro Files 

Old Path:  C:\Program Files\ExpertCAD\expcad\macros 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAD Macros 

 
ExpertCAM User Interface Macro Files 

Old Path:  C:\Program Files\ExpertCAD\expcam\macros 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAM Macros 

 
ExpertCAD Example Files 

Old Path:  C:\Program Files\ExpertCAD\expcad\examples 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAD Examples 

 
ExpertCAD Custom Configuration File for All Users 

Old Path:  C:\Program Files\ExpertCAD\expcad\global.cfg 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAD.cfg 

 
ExpertCAM Custom Configuration File for All Users 

Old Path:  C:\Program Files\ExpertCAD\expcam\global.cfg 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAM.cfg 

 
ExpertCAD Custom Configuration File for Current User 

Old Path:  C:\<User’s Profile Folder>\expcad.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD.cfg 

 
ExpertCAM Custom Configuration File for Current User 

Old Path:  C:\<User’s Profile Folder>\expcam.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM.cfg 

 
ExpertCAD Settings Established in the Options Dialog (SET-UP menu in previous versions) 

Old Path:  C:\<User’s Profile Folder>\cadsetup.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-Setup.cfg 

 
ExpertCAM Settings Established in the Options Dialog (SET-UP menu in previous versions) 

Old Path:  C:\<User’s Profile Folder>\expcam.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM-Setup.cfg 
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ExpertCAD Custom Short Key Definitions 
Old Path:  C:\<User’s Profile Folder>\cadshort.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-ShortKeys.cfg 

 
ExpertCAM Custom Short Key Definitions 

Old Path:  C:\<User’s Profile Folder>\expcamshorts.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM-ShortKeys.cfg 

 
ExpertCAD Custom Cursor Stroke Definitions 

Old Path:  C:\<User’s Profile Folder>\cadstrks.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-Strokes.cfg 

 
ExpertCAM Custom Cursor Stroke Definitions 

Old Path:  C:\<User’s Profile Folder>\expcamstrokes.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM-Strokes.cfg 

 
ExpertCAD Custom Colors Defined Using the Color Editor Dialog 

Old Path:  C:\<User’s Profile Folder>\cadcolor.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-Colors.cfg 

 
ExpertCAM Custom Colors Defined Using the Color Editor Dialog 

Old Path:  C:\<User’s Profile Folder>\expcamcolors.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM-Colors.cfg 

 
ExpertCAD Standard Text Note Definitions 

Old Path:  C:\<User’s Profile Folder>\cadnotes.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-StandardNotes.cfg 

 
ExpertCAD Custom Quick Menu (Graphic Popup Menu) 

Old Path:  C:\<User’s Profile Folder>\cadpopup.cfg 
New Path:  C:\<Personal application data>\ ExpertCAD-QuickMenu.cfg 

 
ExpertCAM Custom Quick Menu (Graphic Popup Menu) 

Old Path:  C:\<User’s Profile Folder>\expcampopup.cfg 
New Path:  C:\<Personal application data>\ ExpertCAM-QuickMenu.cfg 

 
ExpertCAM Post Processor Configuration File 
     Old Path:  C:\Program Files\ExpertCAD\expcam\posts\expcamposts.cfg 
     New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAM-Posts\ExpertCAM-Posts.cfg 
 
ExpertCAM Post Processor Files & Folders 

Old Path:  C:\Program Files\ExpertCAD\expcam\posts\ 
New Path:  C:\ProgramData\SofTech\ExpertCAD\ExpertCAM-Posts\ 

 
During installation, the files and folders that pertain to all users are migrated (copied and 
renamed) to their proper location.  You do not have to manually copy and rename any of these 
files. 
 
The first time you run ExpertCAD or ExpertCAM, the programs will look for personal configuration 
files from a previous release.  If any of these files exist, they will be migrated (copy and renamed) 
to reflect their proper location in the new installation scheme. 
  
When installing on a system that did not have a previous version of the software installed, default 
configuration files will be installed.  If you have customized configuration files from a previous 
release, you will need to copy these to their new location manually. 
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Closed Track IDs 
The following is a list of closed customer and internally generated software enhancements, 
corrections and modifications included in this release with a synopsis of the problem or 
enhancement that has been addressed. 
ID Synopsis 
62 Call to a symbol causes the screen to erase and redraw unnecessarily. 
88 Double-click in the File dialog can cause a point to be added to the current line. 
194 Add an option or command to allow a dialog to be posted for choosing directories only. 
302 Installation is incorrect & incomplete when installing on a terminal server edition of Windows. 
319 Double-click in the File dialog can cause a point to be added to the current line. 
394 Installation can cause conflicts with prior editions of ExpertCAD. 
419 Add help messages when tracking over graphic pop-up menus to describe their function. 
596 Add additional user preferences to ExpertView (scroll lines, printing & plotting options). 
605 Choosing pointer focus for window activation can cause the application to hang. 
639 ExpertCAD will overwrite files that are designated as read-only. 
650 Change the way the “Save As” feature works to conform to Windows standard. 
661 Add support for the terminal server editions of MS Windows. 
767 Add help messages in the status bar when tracking over menus (pull-down and pop-ups). 
791 Add ExpertCAD as an option when choosing Custom for installation. 
804 Add a most recently used file listing to the File menu. 
819 The menu-stick feature is not working properly for the measure-angle graphic popup. 
827 Add ExpertCAD as an option when choosing Custom for installation. 
837 Add e-mail “Send to Mail Recipient” as a feature in the File menu. 
917 Add the ability to drag & drop a file into an ExpertCAD window. 
1011 User interface for sizing balloon notes is not intuitive. 
1019 Add a tabbed Options dialog to replace the SET-UP popup menu. 
1092 Memory allocation for IGES translation is inefficient. 
1098 Installation should not overwrite library macros for mold components. 
1179 Change the way the “Save As” feature works to conform to Windows standard. 
1252 Add a most recently used file listing to the File menu. 
1337 Add ability to change the number of lines in the scroll area for ExpertView 
1338 Add user interface to the shrink factor for printing to ExpertView. 
1428 Add ability to be able to re-program the pull-down menus from a macro. 
1433 Change the File menu to conform to Windows standards for application software. 
1449 Application does not start unless the user has write privileges for eXceed directory.  
1465 Contents of some dialog items are cleared when a resize event occurs. 
1546 Add ability to be able to re-program the pull-down menus from a macro. 
1565 Cursor sometimes jumps across the screen when choosing an item from the Measure popup. 
1566 Popup menus post off the screen if the cursor is too close the edge of the window. 
1638 Ensure the proper extension (.dxf or .dwg) is added to the file name when writing to AutoCAD. 
1752 Increase the number of icons that can be inserted into a graphic popup menu. 
1831 Remove unwanted entry in system registry for printing. 
1871 Remove icon pad for choosing a library. 
1872 The per-bisector construction line feature fails if point is at the center of a circle. 
1892 ExpertCAD will sometimes not allow a read-only file to be opened. 
1902 The right Alt key does not function properly.  Should give focus to the menus. 
1913 Popup menus post off the screen if the cursor is too close the edge of the window. 
1914 Cursor position is incorrect if the measure graphic popup is posted to close window edge. 
1915 Increase the number of icons that can be inserted into a graphic popup menu. 
1973 Add help messages when tracking over graphic pop-up menus to describe their function. 
2082 Screen does not remain inverted if File/Clear is chosen. 
2123 The appearance of the pull-down menus is poor when running with an inverted screen. 
2201 The set-lib command sometimes fails to function properly. 
2211 The count in the layer dialog is off by 1 for lines.   
2225 Missing menu item “What’s New” in the Help menu for ExpertView. 
2247 Add ability to get the full path names for system variables line INSTALL_PATH. 
2266 File dialog should be posted the first time a call to a symbol is requested. 
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2267 The “Circle Tangent to 2 Entities” construction line doesn’t work if 2 circles are input. 
2271 Default action for the short key ‘Del’ should delete all selected entities. 
2318 Add e-mail “Send to Mail Recipient” as a feature in the File menu. 
2331 The default font for dialogs is poor.  Would prefer a larger font size. 
2384 Add Windows-style dialog and behavior for the Find Text feature. 
2389 Remove dependency on an X-Windows server for display. 
2393 Add ability to save a drawing is HSF format. 
2489 Add ability to reprogram what the mouse wheel does. 
2499 Titles in some dialogs are not correct.  Title should reflect the function of the dialog. 
2505 Add support for the tilt-wheel mouse feature. 
2506 Add support for the Forward & Back mouse buttons. 
2512 Revise installation scheme to put configuration files in the appropriate directories. 
2530 Capture feature is broken. 
2531 Revise installation to place help files in a directory separate from program files. 
2543 Entering text into a edit box in a dialog gets erased if a redraw occurs. 
2544 This section in ExpertCAM gets distorted when its direction is reversed. 
2550 Incorrect processing messages for IGES translator. 
2551 The .txt filter should be used in the file dialog for the File to Current Text feature in ExpertCAD. 
2552 Title block in this AutoCAD DWG drawing is missing after translation to ExpertCAD 
2571 Embed Microsoft-standard version information in all binary executable files. 
2579 This IGES data file will not convert to ExpertCAD format. 
2580 Add default behaviors for Ctrl-click and Shift-click mouse events. 
2583 Add the ability to write IGES data by class in ExpertCAD. 
2585 Unnecessary and unwanted fonts are being installed when ExpertCAD is installed. 
2594 When ExpertView is installed by itself, the GNU software does not get installed. 
2595 Diameter dimensions (dimen 6) does not always draw in the dimension color (UNIX only). 
2596 The –QB command line option for batching does not work in Version 7.7 of ExpertCAD 
2598 This DXF file will not convert to ExpertCAD format. 
2601 This AutoCAD DWG file will not convert to ExpertCAD format. 
2617 This AutoCAD DWG file will not convert to ExpertCAD format. 
2622 When using wide lines, arrowheads for dimensions extend past the leader lines in PDF output. 
2624 ExpertCAM is ignoring the go-to directory setting when working with databases. 
2628 Batch output from WinPlot can be different than when it is run interactively. 
2630 Calls to symbols with invisible entities become visible when converted to AutoCAD format. 
2631 The AutoCAD solid fill entity in this file is not converting properly to ExpertCAD format. 
2636 Can’t read this Cadra file into ExpertCAD on an AMD system.  Intel-based computers are OK. 
2637 Can’t convert this IGES file to ExpertCAD. 
2638 ExpertCAD can’t read this Cadra file. 
2639 Confusing errors emitted if the radius of a circle tangent to 2 circles is too small. 
2640 This DXF file will not convert to ExpertCAD format. 
2642 Add a command line option to allow selection of ExpertCAD or ExpertView license. 
2643 This DXF file will not convert to ExpertCAD format. 
2644 2 text notes in this AutoCAD drawing are not being translated properly. 
2646 Block entities in this AutoCAD file that are not scaled correctly when translated to ExpertCAD. 
2647 Add support for reading & writing AutoCAD 2007/2008 files. 
2652 A segmentation violation error is reported when this ExpertCAD file is edited. 
2653 Purge text buffers should not report buffers associated with text notes as unnecessary. 
2655 Enhance Cut & Copy to place a bitmap of the data on the clipboard. 
2656 Can’t convert this IGES file to ExpertCAD. 
2657 Can’t read this Cadra file into ExpertCAD. 
2658 On edit, clear out all non-standard dimension characters before reading the file. 
2659 Disabling the auto position text feature for dimensions doesn’t work for vertical dimensions. 
2661 Writing a PDF file causes ExpertCAD to think that the drawing has changed somehow. 
2662 Add the ability to print multiple copies of a drawing. 
2667 The text in this AutoCAD drawing is shifted slightly in X when translated to ExpertCAD 
2668 Default the system of units used as the default based on the locale information from Windows. 
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	Welcome to the next generation of ExpertCAD & ExpertCAM for Windows.  The applications have been transformed into true Windows applications.  As a necessary part of this transformation, the user interface has been dramatically changed to adopt Windows-st
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	ExpertCAD 2007 for Windows
	This document will serve as your guide to these major changes in the user interface including the new features and functions now possible.  Although major changes have been made, you will find it very easy to adapt to this new version because wherever po
	Windows User Interface Overview
	This section describes the changes to the user interface.  The examples shown are for ExpertCAD.  ExpertCAM has identical or very similar changes to its user interface as well.
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	The same general layout of the window has been retained:
	Windows menus along the top of the window.
	Central graphics area for display of the drawing or NC cutter path.
	Static icons along the right-hand side.
	Pop-up menus.
	A message area at the bottom of the screen for prompts and messages.
	Status Bar
	A Windows-style status bar has been added to the bottom of the window:
	�
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	In the left-most cell of the status bar, the coor
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	The left-most cell is also used to show a 1-line help string when tracking icons, menus or pop-up menus.  Informational messages are also displayed here such as the coordinates of a point dropped or what the last short command just did:
	�
	Tracking over any menu item or icon posts a 1-line help message.
	A progress meter is shown in the left-most cell for operations that can take more than several seconds to complete.  There are 2 styles of progress meters:
	�
	The discrete  progress meter is used for operations where actual progress towards completion can be measured.
	�
	The marquee-style progress meter is shown when a 
	Keystroke Commands
	Where possible, all the standard factory-settings for keystroke commands have been retained.  Some important changes to be aware of include:
	The ‘Esc’ key replaces the Ctrl-C key combination
	Because of the change to handling the Esc command
	The ‘F1’ key defaults to Help/Contents.  In previ
	Throughout the user interface, keystroke commands have been implemented to conform to Windows standard.  If there are keystroke commands for a feature/function in a pull-down menu, the keystroke is listed in the menu item:
	�
	In the File menu, Ctrl+O is the keystroke combination to open a file.  Similarly Ctrl-N will start a new drawing.  Both are Windows standard keystrokes for these features.
	Mouse Button Assignments
	The applications default to the traditional mouse-button assignments although these can be changed according to your preferences in the User Preferences tab of the Tools/Options property sheet.  By default the button assignments are:
	Left-mouse button – digitize points & cursor stro
	Middle-mouse button – activate pop-up menus.
	Right-mouse button – track the static icon area.
	In addition to these 3 standard mouse buttons, su
	�
	The left-right tilt-wheel, while not programmable, is recognized by the software and by default will operate the horizontal scroll bar (scroll-left, scroll-right).
	In ExpertCAD, default behavior is defined when the Ctrl or Shift key is held down while digitizing in the graphics area.  Ctrl will select (or unselect) the entity near the cursor (i.e. toggle the selected state).  Shift will select the entity near t
	Scroll Bars
	Horizontal and vertical scroll bars for scrolling a drawing left/right, up/down are enabled by default in ExpertCAD.  The scroll bars function according to Windows standard.  If you wish reclaim some graphics area, the scroll bars can be disabled and hid
	Drag & Drop Support
	Windows-standard drag & drop of files into the application window is supported.  In ExpertCAD, if a file is currently being edited, the file is inserted into the drawing otherwise the file is opened and becomes the current file being edited.  In ExpertCA
	Popup Menus
	Popup menus are Windows-style pull-right menus as opposed to the stacking-style in previous releases.  The title of the pull-right appears in the main menu with its contents in the pull-right.
	�
	Pop-up menus are used for those features/functions that are dependent on the position of the cursor at the time the function is used.
	If preconditions for using an item in the menu are not met, the item is disabled.  In this example, there is no current text so the menu item Delete Current Text is disabled.
	All items in popup menus (graphics and textual menus) have 1-line help messages that are displayed in the status bar when that item is tracked.
	Many of the features implemented in popup menus in previous releases have migrated to the pull-down menus.  Operations that require pre-positioning of the cursor are implemented as popup menus.
	The ‘menustick’ \(default menu item\) feature �
	If you use the library feature, the modules you specify to use will be added to the main popup menu:
	�
	In this example, the parametrics, mold components and user library are requested.
	To bring up the user interface for the library, choose its icon in the graphics popup menu.
	Note that there are 1-line help messages shown in the status bar when you track over an icon in any graphic popup menu.
	Here is an overview of the new set of popup menus in ExpertCAD 2007:
	�
	The Find Delete menu is a renamed version of the former FIN/DEL menu.
	The same features and functions are provided with menu items that provide for greater clarity.
	Notice that menu items are disabled when conditions for the proper usage do not exist.
	�
	The Point Edit menu is a renamed version of the former PT EDIT menu.
	The menu retains the same order and functionality as previous releases.  The menu items themselves have been modified for clarity as to their purpose.
	Note the menu item Filter by Class has a checkmark next to it.  This indicates that the Filter by Class is currently enabled.  Choosing this menu item will toggle its state on and off.
	Here again, menu items are disabled when pre-cond
	�
	The Measure popup menu is functionally the same as in previous releases.  For clarity the icons have been revised in appearance and 1-line help is provided in the status bar when an icon is highlighted.
	�
	Drawing Xtras is a replacement for the former DRAW popup menu.  Included in this menu are the features that modify the current line most of which are dependent on the cursor position.
	Dialogs
	Windows-style dialogs are used throughout the applications.  The former proprietary dialog look and feel has been discarded.  In addition to Windows-standard dialogs, specialized dialogs have been added for consistency where required:
	�
	�
	The Layer Manager dialog has been converted to a Windows dialog and reworked to make it easy to delete, rename or create new named layers because they work per Windows standard.
	The Line Style dialog shows the true dash pattern and width of each line style available
	�
	�
	The Font dialog lists all fonts currently available and provides a preview of your selection.
	The color dialog shows all available color choices with one-click selection.
	ExpertCAD Menus
	The menu set has been modified to conform closely to Windows standards and common practice for organization and function.  The menus themselves follow Windows standards for usage:
	�
	The menus can be navigated using your mouse or the keyboard by using the Alt keystroke in combination with other keystrokes.  Underlined characters indicate the key to use to navigate to that item.
	If there is a keystroke (short command) associated with a menu item, it will be listed on the menu to right of the text for that item (e.g. the Del key will perform the same function as Edit/Delete).
	In all cases, menu items are disabled if the proper conditions do not exist to use that item.  In this example, Redo is disabled because we have not done an Undo yet.  Similarly Paste is disabled because there is nothing suitable on the clipboard to past
	When you track over a menu item, a 1-line help message will be shown in the status bar to describe its function.
	The new menu set for ExpertCAD is shown below:
	�
	The following is an overview of the menus that have changed or have been added for ExpertCAD 2007:
	�
	New – start a new drawing.  This is the same func
	Open – edit a drawing.  This is the same function
	Save – save the current drawing.
	Save As - save the current drawing to a different file name.  Note that the file specified becomes the current edit file.
	Save Current Class – save only those drawing item
	Export – write the drawing to a file in your choi
	�
	Options for exporting files can be set on the Import/Export tab of the Tools/Options property sheet.
	HSF is a new option to output the drawing in Hoops Streaming Format.  This format can be read by popular viewing programs such as SolidWorks eDrawings.
	Windows Bitmap writes the drawing as a .bmp file 
	Send To – forward the drawing data as e-mail or t
	�
	Page Setup – establishes the printer, paper size,
	Print – print all or part of the drawing.  Printi
	Plot – plot all or part of the drawing using the 
	Properties – displays the drawing properties dial
	Recent Files – lists the last 8 most recent files
	�
	Undo – reverses the effect of the last change to 
	Redo – roll-forward the last operation that was u
	Cut – puts only the selected drawing entities on 
	Copy – puts only the selected drawing entities on
	Paste – inserts the contents of the clipboard at 
	Select All – selects all drawing entities.
	Delete – deletes all selected drawing entities.
	Notes on Cut/Copy/Paste….
	When you use Cut or Copy, the selected entities are written to the system clipboard in ExpertCAD format and as a Windows bitmap.  This allows you to paste the items you selected into another session of ExpertCAD as drawing entities or into another applic
	When you use Edit/Paste in ExpertCAD, it will choose to use native ExpertCAD data if it is available on the system clipboard.  If that format does not exist, it will choose to use a text format if that is available and insert the data as a text note.  Th
	�
	The View pull-down menu replaces the former popup View menu in previous releases.
	Redraw – clears the graphics area and redraws.
	Zoom to Fit – fits the drawing to the graphics ar
	Zoom to Area – zooms into an area you indicate us
	Zoom In/Out – dynamic zoom in/out using the mouse
	Zoom to Scale – set the view scale to a value you
	Zoom by Factor – scale the view scale by a factor
	Pan – dynamically pan using the mouse.
	Previous View – return the previous view orientat
	Display Grid – show or disable a visible grid.
	�
	Insert is a new menu that implements certain functions formerly found on the File menu.
	Drawing – inserts \(merges\) a drawing into th�
	New Symbol – creates a symbol from an ExpertCAD f
	Call to a Symbol – places a call to a symbol at t
	Update Symbol Definition – updates the definition
	�
	Tools is a new menu that consolidates various features that were formerly scattered throughout other menus in previous versions.
	Screen Capture – using the mouse, indicate an are
	Engineering Change - posts the engineering change dialog to perform a difference between 2 drawings.
	Purge – rids the drawing data of unused and/or un
	Layer Manager – posts the layer manager dialog to
	Color Editor – posts the color editing dialog to 
	Options – posts the Options property sheet to set
	The Draw menu replaces the former POINT and BUILD popup menu.  The same features and functions have been consolidated into this single menu:
	�
	�
	�
	The Draw Menu
	The Points Submenu
	The Splines Submenu
	Tools/Options Property Sheet
	The Options property sheet replaces the functions formerly found in dialogs posted from the SET-UP popup menu.
	�
	Clicking on a tab on the property sheet brings that dialog to the forefront for entering your preferences.
	Click OK to accept changes to all the dialogs.  Click Apply to accept changes to the current dialog.  The settings will be saved to your personal configuration file:
	C:\<Personal application data>\ SofTech\ExpertCAD\ExpertCAD-Setup.cfg
	Where <Personal application data> is typically:
	Windows 2000/XP - C:\Documents and Settings\<user>\Application Data
	Windows Vista - C:\Users\<user>\AppData\Roaming
	Never edit the file ExpertCAD-Setup.cfg.  This file is created and re-written by the Options dialog.  Any changes or edits you might make will be lost the next time you use the Options dialog to change a setting.
	Printing from Windows in ExpertCAD and ExpertView
	The print feature has been completely redone to allow more flexibility and choices for output.
	Page Setup has been added to the File menu to allow you to choose a default printer and set the characteristics for that printer.  The choices you make in the Page Setup dialog will be used as the default when you print although you will have the option
	In the Print/Plot dialog in the Tools/Options property sheet, you can choose to set the scale at which you want the drawing to be printed:
	�
	The Fit drawing to paper switch is enabled by default.  This means that ExpertCAD will scale the output to fit the drawing to the paper size you have chosen taking into account the current margins.
	�
	If you want to print at a specific scale, un-chec
	Regardless of whether you choose the Fit option or a specific scale, the scaling method aligns the center of your drawing with the center of the printable area of the page as specified by the paper size and margins.  The scale is applied relative to this
	Line width replaces the function of the former “L
	The ability to print multiple copies is supported provided your printer supports this feature.
	AutoCAD 2007/2008 Support
	The AutoCAD translators have been updated to allow for read and write of AutoCAD 2007 and 2008 files.  If you wish to output this version of the AutoCAD format, choose 2007/2008 from the Output version menu on the Import/Export tab on the Options dialog:
	�
	Platform Support
	Installation
	New Paths for Configuration Files
	Closed Track IDs


